A new Delphi version (10.3 Rio) was released recently and again there’s no Advantage Database Server component kit available. So it’s time to do it again. As already described here and here, you just need to edit versions.inc.
The new compiler version is 330:

{$IFDEF VER330}
   {$DEFINE ADSDELPHIRIO}
{$ENDIF}

//...

{$DEFINE ADSDELPHIRIO_OR_NEWER}
{$IFNDEF ADSDELPHIRIO}

This version of Delphi/C++Builder is not yet supported!

{$ENDIF}

Make a copy of \program files (x86)\Advantage 12.0\TDataset\DelphiXE10.1, name it DelphiXE10.3. Then replace all occurences of version.inc of that folder with the edited one.
Launch Delphi/RadStudio as Administrator, open the runtime package, save it as adsdxe10RioStudio and build. Then open the design time package, save it as adsdxe10RioDStudio, remove adsdxe10TokyoStudio.dcp from the requires part and replace it with adsdxe10RioStudio.dcp. Build the project and install the components. That’s it!

ADS and Delphi 10.3 Rio
Markiert in:             

6 Gedanken zu „ADS and Delphi 10.3 Rio

  • 5. Dezember 2018 um 17:03
    Permalink

    Ich habs mir fast gedacht… so kann denn das tote Pferd noch eine Weile geritten werden.

    Antworten
  • 5. Februar 2019 um 22:03
    Permalink

    I’ve tried this many times, everything is fine until the very last click on „Install“. I get a

    dcc32 Error E2466 Never-build package ‚.adsdxe10Riodstudio‘ requires always-build package adsdxe10Riostudio‘

    I’ve tried using a different folder, using the original projects without renaming them, and I also get this error when trying to install:

    Can’t load package C:\Users\Public\Documents\Embarcadero\Studio\20.0\bpl\adsdxe10Riostudio.bpl. The Specified module could not be found.

    That file does exist, with the time/date that is just a minute old. In my path I have

    c:\Program Files\Embarcadero\Studio\20.0\bin
    c:\Program Files\Embarcadero\Studio\20.0\bpl
    c:\Program Files\Embarcadero\Studio\20.0\dcp
    c:\Program files\Advantage 12.0\TDataSet\Rio\Win32
    c:\Program files\Advantage 12.0\TDataSet\Rio\Win32\Source

    Antworten
    • 5. Februar 2019 um 22:12
      Permalink

      Doug,
      for the examples I changed the output directory to ./

      Antworten
      • 5. Februar 2019 um 22:35
        Permalink

        I tried changing the DCP output directory to ./ and the package output to ./ I did this for both projects.

        I get the same error but in the local folder

        Can’t load package c:\Program files\Advantage 12.0\TDataSet\Rio\Win32\Source. The Specified module could not be found.

        I really appreciate your help!!!

        Antworten
  • 6. Februar 2019 um 16:23
    Permalink

    Did you copy the (correct) client engine DLLS to the Windows system (syswow64) folder?

    Antworten
  • 7. Februar 2019 um 0:10
    Permalink

    My main PC has C++ Builder, so I cannot compile the Advantage source code. So I ZIPPED the files from the Delphi PC, the entire \Program Files\Advantage 12.0 folder, then unzipped onto my C++ Builder PC. I searched \Windows for all of the required DLL’s and the AdsAdditionalDesigners.dll and made sure there was 1 copy of each and that they were all version 12.0. The file aicu32.dll was installed in the ARC and SERVER folders, as well as REDISTRIBUTE folder and the file in REDISTRIBUTE was 64 bytes smaller than the other 2 files. I used the file in the REDISTRIBUTE folder. I then tried to „Install Packages“. It failed, saying it could not find a file. I copied the two .BPL files (adsdxe10RioStudio.bpl and adsdxe10RiodStudio.bpl) to \Program files (x86)\Embarcadero\Studio\20.0\bin. I then tried „Install Packages“, and browsed to the \Program files (x86)\Embarcadero\Studio\20.0\bin folder and installed adsdxe10RiodStudio.bpl successfully. I think the .BPL files need to be in the Windows PATH.

    The reason I needed to install 12.0 was because after I installed Rio I have a table that has a MONEY field type shows a random value if the field is null. I thought my 11.10 Advantage installation was corrupt or had mismatched DLL’s since I have had so many versions of Advantage over the years. After installing 12.0 and building that project I have the same issue. A picture of the issue is here http://www.douglashay.com/tracks/advantage1.JPG

    Antworten

Schreibe einen Kommentar zu Joachim Höhne Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.